如何修复 Linux Bash漏洞
当前位置: 主页  »  技术文章

如何修复 Linux Bash漏洞

来源:本站 发布时间:2014-9-26 16:11:34 浏览量:

刚收到邮件,说是linux内置的bash中发现了一个严重的安全漏洞,黑客可以利用该漏洞完全控制目标系统并发起攻击。今天我们来说下怎么修复该漏洞:

已经被确认成功利用该漏洞的软件和系统,所有安装了 GNU bash版本小于等于4.3的linux操作系统.


首先我们先要检测是否存在该漏洞(小于等于4.3的linux操作系统存在)

漏洞检测命令:env x='() { :;}; echo vulnerable' bash -c "echo this is a test"   

执行命令后,如果显示包含vulnerable 说明有漏洞.


然后根据你的服务器的版本来选择修复方案,我的是Centos所以用下面的语句

yum -y update bash